kernel: load softdog on boot
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Nov 2015 10:53:11 +0000 (10:53 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Nov 2015 10:53:11 +0000 (10:53 +0000)
same as for hardware watchdogs, otherwise
procd cannot initialize it.

Signed-off-by: Ulrich Weber <uw@ocedo.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47394 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 022410f..73251b8 100644 (file)
@@ -408,7 +408,7 @@ define KernelPackage/softdog
   TITLE:=Software watchdog driver
   KCONFIG:=CONFIG_SOFT_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/softdog.ko
-  AUTOLOAD:=$(call AutoLoad,50,softdog)
+  AUTOLOAD:=$(call AutoLoad,50,softdog,1)
 endef
 
 define KernelPackage/softdog/description