kernel: make kmod-thermal dependency conditional to match upstream kernel module...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Dec 2015 19:05:35 +0000 (19:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Dec 2015 19:05:35 +0000 (19:05 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47961 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index ad1c7bf..e09efa1 100644 (file)
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
   KCONFIG:=CONFIG_SENSORS_GPIO_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
-  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-gpiofan/description