projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
09976aa
)
rules.mk: reduce shexport to one line to allow it to be put in a target context
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:20 +0000
(08:57 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:20 +0000
(08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43018
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
rules.mk
patch
|
blob
|
history
diff --git
a/rules.mk
b/rules.mk
index
8844a47
..
0822979
100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-278,8
+278,7
@@
V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
endef
define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
+export $(call shvar,$(1))=$$(call $(1))
endef
define include_mk