projects
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1745f44
)
host-build: add HOST_MAKE_FLAGS similar to package MAKE_FLAGS
author
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Sep 2012 20:10:28 +0000
(20:10 +0000)
committer
nbd
<nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Sep 2012 20:10:28 +0000
(20:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33509
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
include/host-build.mk
patch
|
blob
|
history
diff --git
a/include/host-build.mk
b/include/host-build.mk
index
e011c15
..
66795c8
100644
(file)
--- a/
include/host-build.mk
+++ b/
include/host-build.mk
@@
-69,6
+69,8
@@
HOST_CONFIGURE_ARGS = \
--localstatedir=$(STAGING_DIR_HOST)/var \
--sbindir=$(STAGING_DIR_HOST)/bin
+HOST_MAKE_FLAGS =
+
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
@@
-95,7
+97,9
@@
define Host/Configure
endef
define Host/Compile/Default
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) $(1)
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+ $(HOST_MAKE_FLAGS) \
+ $(1)
endef
define Host/Compile