ar71xx: image: use the MultiProfile helper for the Madwifi profile
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 23 Aug 2012 13:11:25 +0000 (13:11 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 23 Aug 2012 13:11:25 +0000 (13:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33262 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 58b3173..c0a1a9d 100644 (file)
@@ -887,14 +887,7 @@ $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523
 
 $(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
 $(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
-
-define Image/Build/Profile/Madwifi
-       $(call Image/Build/Profile/EAP7660D,$(1))
-       $(call Image/Build/Profile/UBNTRS,$(1))
-       $(call Image/Build/Profile/UBNTRSPRO,$(1))
-       $(call Image/Build/Profile/UBNTLSSR71,$(1))
-       $(call Image/Build/Profile/WP543,$(1))
-endef
+$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
 
 define Image/Build/squashfs
        cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-raw