kernel: add mvsw61xx module package
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Oct 2015 10:10:41 +0000 (10:10 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Oct 2015 10:10:41 +0000 (10:10 +0000)
Adds the package to select the mvsw61xx module present in the 3.18/4.0/4.1
kernels.

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47224 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netdevices.mk

index 9efac98..ef3cf85 100644 (file)
@@ -180,6 +180,20 @@ endef
 
 $(eval $(call KernelPackage,swconfig))
 
+define KernelPackage/switch-mvsw61xx
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Marvell 88E61xx switch support
+  DEPENDS:=+kmod-swconfig
+  KCONFIG:=CONFIG_MVSW61XX_PHY
+  FILES:=$(LINUX_DIR)/drivers/net/phy/mvsw61xx.ko
+  AUTOLOAD:=$(call AutoLoad,42,mvsw61xx)
+endef
+
+define KernelPackage/switch-mvsw61xx/description
+ Marvell 88E61xx switch support
+endef
+
+$(eval $(call KernelPackage,switch-mvsw61xx))
 
 define KernelPackage/switch-ip17xx
   SUBMENU:=$(NETWORK_DEVICES_MENU)