projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a2f5118
)
kernel: add new core sound module snd-pcm-dmaengine.ko for 3.12 kernels and above
author
Zoltan HERPAI
<wigyori@uid0.hu>
Tue, 12 Nov 2013 01:09:15 +0000
(
01:09
+0000)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Tue, 12 Nov 2013 01:09:15 +0000
(
01:09
+0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38772
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
package/kernel/linux/modules/sound.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/sound.mk
b/package/kernel/linux/modules/sound.mk
index
28b9890
..
4e1a656
100644
(file)
--- a/
package/kernel/linux/modules/sound.mk
+++ b/
package/kernel/linux/modules/sound.mk
@@
-40,6
+40,14
@@
SOUNDCORE_FILES += \
$(LINUX_DIR)/sound/core/snd-compress.ko
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
+SOUNDCORE_LOAD += \
+ snd-pcm-dmaengine
+
+SOUNDCORE_FILES += \
+ $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+endif
+
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)
TITLE:=Sound support