openssl does not compile with uml and arch x86_64
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jun 2012 23:54:08 +0000 (23:54 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jun 2012 23:54:08 +0000 (23:54 +0000)
Hi,

I found that openssl did not compile on the uml target under x86_64. The
attached patch should
correct this and is working for me. Is this the right way to do it?

thanks,
Thomas

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32443 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openssl/Makefile

index a696dd7..7043aee 100644 (file)
@@ -82,11 +82,16 @@ else
   OPENSSL_OPTIONS += no-engines
 endif
 
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+  OPENSSL_TARGET:=linux-x86_64
+else
+  OPENSSL_TARGET:=linux-openwrt
+  OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
-               ./Configure linux-openwrt \
+               ./Configure $(OPENSSL_TARGET) \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
                        $(TARGET_CPPFLAGS) \