projects
/
10.03
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c756188
)
[backfire] backport r22517
author
agb
<agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Dec 2010 21:41:04 +0000
(21:41 +0000)
committer
agb
<agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Dec 2010 21:41:04 +0000
(21:41 +0000)
[include] support unpacking of .tar.xz archives, no prereq on xzcat for now
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@24524
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
include/unpack.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index
2cd1781
..
0151675
100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-32,7
+32,11
@@
ifeq ($(strip $(UNPACK_CMD)),)
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
endif
- ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
+ ifeq ($(filter xz txz,$(EXT)),$(EXT))
+ EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
+ DECOMPRESS_CMD:=xzcat $(DL_DIR)/$(PKG_SOURCE) |
+ endif
+ ifeq ($(filter tgz tbz tbz2 txz,$(EXT1)),$(EXT1))
EXT:=tar
endif
DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |