[backfire] merge r23248, r23249, r23250, r23251 and r23252
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Oct 2010 15:20:04 +0000 (15:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Oct 2010 15:20:04 +0000 (15:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23298 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2/Makefile
package/iproute2/Makefile
package/mmc_over_gpio/Makefile
package/mountd/Makefile
package/ppp/Makefile

index d02b435..898ec30 100644 (file)
@@ -15,7 +15,7 @@ PKG_RELEASE:=2
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2 
+PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 #PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 #PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
@@ -36,6 +36,10 @@ define Package/hotplug2/description
  This is an implementation of Hotplug2-1.0-beta
 endef
 
+define Package/hotplug2/conffiles
+/etc/hotplug2.rules
+endef
+
 MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
index 9eec69e..63f4dbc 100644 (file)
@@ -30,6 +30,10 @@ $(call Package/iproute2/Default)
   TITLE:=Routing control utility
 endef
 
+define Package/ip/conffiles
+/etc/iproute2/rt_tables
+endef
+
 define Package/tc
 $(call Package/iproute2/Default)
   TITLE:=Traffic control utility
index 5a3ab1d..9c14a69 100644 (file)
@@ -51,6 +51,10 @@ define KernelPackage/mmc-over-gpio/description
  Support for driving an MMC/SD card over GPIO pins via SPI.
 endef
 
+define KernelPackage/mmc-over-gpio/conffiles
+/etc/config/mmc_over_gpio
+endef
+
 define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
index bfee358..c591376 100644 (file)
@@ -25,6 +25,10 @@ define Package/mountd/description
   openwrt automount daemon
 endef
 
+define Package/mountd/conffiles
+/etc/config/mountd
+endef
+
 define Build/Compile
        $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)" \
@@ -40,4 +44,3 @@ define Package/mountd/install
 endef
 
 $(eval $(call BuildPackage,mountd))
-
index f24ddb6..d670f33 100644 (file)
@@ -39,6 +39,16 @@ define Package/ppp/description
 This package contains the PPP (Point-to-Point Protocol) daemon.
 endef
 
+define Package/ppp/conffiles
+/etc/ppp/chap-secrets
+/etc/ppp/filter
+/etc/ppp/ip-down
+/etc/ppp/ip-up
+/etc/ppp/ipv6-down
+/etc/ppp/ipv6-up
+/etc/ppp/options
+endef
+
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
@@ -70,6 +80,14 @@ This package contains a RADIUS (Remote Authentication Dial-In User Service)
 plugin for ppp.
 endef
 
+define Package/ppp-mod-radius/conffiles
+/etc/ppp/radius.conf
+/etc/ppp/radius/dictionary
+/etc/ppp/radius/dictionary.asnet
+/etc/ppp/radius/dictionary.microsoft
+/etc/ppp/radius/servers
+endef
+
 define Package/chat
 $(call Package/ppp/Default)
   DEPENDS:=ppp
@@ -142,7 +160,7 @@ define Package/ppp/install
        $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
        ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
 endef
-       
+
 define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \