projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b9d87db
)
package-defaults.mk: set DISABLE_NLS only if not CONFIG_BUILD_NLS
author
John Crispin
<blogic@openwrt.org>
Sat, 21 Mar 2015 21:48:18 +0000
(21:48 +0000)
committer
John Crispin
<blogic@openwrt.org>
Sat, 21 Mar 2015 21:48:18 +0000
(21:48 +0000)
set DISABLE_NLS only if CONFIG_BUILD_NLS NOT set.
like DISABLE_IPV6 which depends on CONFIG_IPV6
Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44930
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
include/package-defaults.mk
patch
|
blob
|
history
diff --git
a/include/package-defaults.mk
b/include/package-defaults.mk
index
9567e04
..
e37ab88
100644
(file)
--- a/
include/package-defaults.mk
+++ b/
include/package-defaults.mk
@@
-67,7
+67,11
@@
ifneq ($(strip $(PKG_UNPACK)),)
endif
EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
-DISABLE_NLS:=--disable-nls
+ifeq ($(CONFIG_BUILD_NLS),y)
+ DISABLE_NLS:=
+else
+ DISABLE_NLS:=--disable-nls
+endif
CONFIGURE_PREFIX:=/usr
CONFIGURE_ARGS = \