target/sunxi: add dependency on sunxi to kmod-wdt-sunxi
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Feb 2014 15:51:11 +0000 (15:51 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Feb 2014 15:51:11 +0000 (15:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39693 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/modules.mk

index 374cef2..a833921 100644 (file)
@@ -70,6 +70,7 @@ $(eval $(call KernelPackage,sun4i-emac))
 define KernelPackage/wdt-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=AllWinner sunXi Watchdog timer
+    DEPENDS:=@TARGET_sunxi
     KCONFIG:=CONFIG_SUNXI_WATCHDOG
     FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sunxi_wdt.ko
     AUTOLOAD:=$(call AutoLoad,51,sunxi_wdt)